Details
Description
The Executor example code has several copies of the line pair:
if (ordType.getValue() != OrdType.LIMIT)
throw new IncorrectTagValue(ordType.getField());
The code would work just as well if it accepted orders of type OrdType.FOREX_LIMIT. Could this be modified to
if (ordType.getValue() != OrdType.LIMIT && ordType.getValue() != OrdType.FOREX_LIMIT)
throw new IncorrectTagValue(ordType.getField());
Even better would be to extract this code to a method called something like validateOrdType(), then you wouldn't need the same code duplicated across all the methods.
Not urgent, I realise this is just example code, but it had me confused for a bit, and is quite easy to fix